Блог для маленьких школьников и их родителей
ШколаЛа
05
Июнь

Г) 3. Написать программный код. [4] Написать программу, которая считает сумму нечётных чисел, произведение…

Автор: orazbekmadina45
Предмет: Информатика
Уровень: 10 - 11 класс

г) 3. Написать программный код. [4] Написать программу, которая считает сумму нечётных чисел, произведение кратных 9 и количество оканчивающихся на цифру 6 чисел из диапазона [a,b] ​

Ответов к вопросу: 1
  • tunayfazilzade4
    05.06.2024 | 21:50

    Ответ:
    Python:
    a = int(input(«От: «))
    b = int(input(«До: «))
    # Создание массива с заданными границами
    array = [i for i in range(a, b+1)]
    # Нечетные числа
    odd_nums = []
    for i in array:
       if i % 2 != 0:
           odd_nums.append(i)
    sum_odd_nums = sum(odd_nums)        
    # Числа кратные 9        
    multiple_of_9 = []
    for i in array:
       if i % 9 == 0:
           multiple_of_9.append(i)
    #Умножение чисел кратных 9
    if not multiple_of_9:  # Проверка, пуст ли список
       multiplication = 0
    else:
       multiplication = 1
       for i in multiple_of_9:
           multiplication *= i
    # Числа заканчивающиеся на 6
    six_nums = 0
    for i in array:
       if i % 10 == 6:
           six_nums += 1
    print(f»nСумма нечётных чисел: {sum_odd_nums}»)
    print(f»Произведение кратных 9: {multiplication}»)
    print(f»Количество чисел оканчивающихся на цифру 6: {six_nums}»)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Ищете ответы на вопрос по г) 3. Написать программный код. [4] Написать программу, которая считает сумму нечётных чисел, произведение кратных 9 и количество оканчивающихся на цифру 6 чисел из диапазона [a,b] ​ для 10 - 11 класс? На странице собраны решения и советы по предмету Информатика, а также обсуждения от других участников. Ответы на этот вопрос уже есть. Вы можете задать свой вопрос, а также стать частью нашего сообщества экспертов.