Блог для маленьких школьников и их родителей
ШколаЛа
27
Июль

Срочно! Задача на Python Дано натуральное число. Напишите программу, которая вычисляет: количество цифр…

Автор: darakasirina17
Предмет: Информатика
Уровень: 10 - 11 класс

Срочно!

Задача на Python

Дано натуральное число. Напишите программу, которая вычисляет:

количество цифр 3 в нем;

сколько раз в нем встречается последняя цифра;

количество четных цифр;

сумму его цифр, больших пяти;

произведение цифр, больших семи (если цифр больших семи нет, то вывести 1, если такая

цифра одна, то вывести ее);

сколько раз в нем встречается цифры 0 и 5 (всего суммарно).

Ответов к вопросу: 1
  • wqlojolpw
    27.07.2024 | 14:06

    Ответ: Тут все сразу по порядку
    n = input()
    print(n.count(‘3’))
    print(n.count(n[-1]))
    print(n.count(‘2’)+n.count(‘0’)+n.count(‘4’)+n.count(‘6’)+n.count(‘8’))
    s = 0
    pr = 1
    for i in n:
       if int(i) > 5:
           s += int(i)
           if int(i) > 7:
               pr *= int(i)
    print(s)
    print(pr)
    print(n.count(‘0’)+n.count(‘5’))

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Задача по Срочно! Задача на Python Дано натуральное число. Напишите программу, которая вычисляет: количество цифр 3 в нем; сколько раз в нем встречается последняя цифра; количество четных цифр; сумму его цифр, больших пяти; произведение цифр, больших семи (если цифр больших семи нет, то вывести 1, если такая цифра одна, то вывести ее); сколько раз в нем встречается цифры 0 и 5 (всего суммарно). для школьников 10 - 11 класс. Узнайте подробное решение и обсудите его с другими участниками. Ответы на этот вопрос уже добавлены. Здесь можно не только получить помощь, но и стать экспертом, помогая другим пользователям.