Запишите выражение на языке программирования Pascal.
Запишите выражение на языке программирования Pascal.
После выполнения программы, записанной на языке Pascal на экран будет выведено: program prim; var s:integer; begin s:=15; write(‘s:=‘,s/3); end. 1) s:=15 2) s=45 3)’s=‘15 4)s= 5
Запишите выражение на языке программирования Pascal.
Дан фрагмент программы:
s:=114.34384
writeln (s:6:2);
После его выполнения на экран будет выведено:
а) 114.34
б) s:=114.34384
в) s:=114.34
г) 114.34384
Расположите в правильном порядке строки программы:
1) S:=a*h;
6) var a,b,h,p,s: integer;
2) end.
7) readln;
3) program pr;
Writeln(‘p=’,p,’ s=’,s);
4) p:=(a+b)^2;
9) a:=5;b:=8;h:=3;
5) begin
2. Установите соответствие между служебными словами и названиями разделов программы:
а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей
3. Определите значение переменной a после выполнения алгоритма:
а := 8
b := 2
b := a/2*b
a := 2*а + 3*b
В ответе укажите одно целое число — значение переменной a.
4.Запишите значение переменной y, полученное в результате работы следующей программы.
var y, i: integer;
begin
y := 0;
for i := 1 to 3 do
y := y + 4 * i;
writeln(y);
end.
5.Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
var t, i: integer;
begin
t := 2;
for i := 1 to 3 do
t := t * i;
writeln(t);
end.
Запусти Паскаль и введи программу:
var
a,b,c:integer;
begin
a:=−43;
b:=abs(a);
writeln(‘abs(−43)=’,b);
c:=sqr(b);
writeln(‘sqr(b)=’,c);
c:=sqr(b+b);
writeln(‘sqr(b+b)=’,c);
end.
При запуске программы вывод на экран:
abs(−43)=
sqr(b)=
sqr(b+b)=
Запишите значение переменной s, полученное в результате работы следующей программы: Var s,k: integer; Begin s := 0; for k := 5 to 13 do s := s + 7; writeln(s); End.
Дан фрагмент программы на языке Паскаль. Определите, что будет напечатано в результате работы этой программы
m:15
n:1
repeat
m:=m-2
n:=n*2
until m<6
writeln(‘m=’,m)
writeln(‘n=’,n)
СРОЧНО! ПЛИЗЗ
Что выведет на экран следующая программа?
Begin
Write(‘Я учусь в’);
Write(2*3+5);
WriteLn(‘ классе.’);
Write(‘Мне’,16,‘лет.’);
WriteLn;
WriteLn(‘Я знаю, что’,‘2*2=’);
Write((6*6-12)/6);
End.
ПЛИИИИИИИИИИИИИИИИИИЗ
1. Сколько бит требуется для кодирования 16,5 млн. цветов (точнее 16 777 216 цветов)?
2. Перевести десятеричное число 100 в шестнадцатеричную систему счисления.
3. Сравнить числа двоичное 1111 0000 и шестнадцатеричное 1 100.
4. А = 0, В = 1. В какой из ниже записанных формул результатом будет 1 (истина)?
А) ¬ В Б) А и В В) ¬ (А или В) Г) ¬ А или ¬ В
5. Как записывается сумма двух чисел А и В в программе на языке Turbo Pascal?
6. Выбрать выражение написанное на языке программирования Turbo Pascal, в
результате которого получено значение с = 2, если а = 14 и b = 4
А) с := a mod b Б) с := b div a В) с := a div b Г) с:= b mod a
7. Найдите значение переменной S после выполнения фрагмента программы на языке
программирования Turbo Pascal:
S := 2;
k := S * 3;
S := sqr (k) — 1;
S := S – k;
8. Вычислите значение переменной x после выполнения фрагмента программы на языке
программирования Turbo Pascal:
a := 2;
b := 3;
c := 4;
if (a – b < 0) and (b > c)
then x := a + b*c
else x := b + c
Помогите исправить эту программу
program pr3;
var x:integer;
begin.
writeln(‘Введите оценку’);
readln(x);
case x of.
1:writeln(‘Плохо’);
2:writeln(‘Неудовлетворительно’);
3:writeln(‘Удовлетворительно’);
4:writeln(‘Хорошо’);
5:writeln(‘Отлично’);
else writeln(‘Ошибка’);
end.
Напишите программу на языке Pascal для следующей задачи: Определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа K, т.е. число K вводится с клавиатуры
Помогите решить. Надо написать на языке паскаль 7 вариант
Скільки разів буде виконано цикл
for x in range (5, -2, -2) ?
1) 7
2) 4
3) 5
4) жодного разу
Артур составляет 5-буквенные коды из букв А, П, О, Р, Т. Каждую букву нужно использовать ровно один раз, при этом нельзя ставить рядом две гласные. Сколько различных кодов может составить Артур?
Напишите с объяснением, пожалуйста
Решите задачу.
У исполнителя имеется две команды:
1. Прибавить 3
2. Отнять 1
Какое минимальное количество команд необходимо выполнить исполнителю для получения числа 9 из числа 2 Выберите один ответ:
a.5
b.2
c.7
d.3
Write a program that lets you know if you can have a key or not, based on your role at the school.
First ask for the user’s role at the school. They can be a student, administrator, or a teacher. (And remember that capitalization is important! ‘Student’ is not the same as ‘student’.)
Example 1: Administrator or Teacher
For example, if this was the input:
Are you an administrator, teacher, or student?: teacher
This should be the output:
Administrators and teachers get keys!
Example 2: Student
And if this was the input:
Are you an administrator, teacher, or student?: student
This should be the output:
Students do not get keys!
(Note: You should also be able to handle a situation where the user enters a value other than administrator, teacher or student and tell them they must be one of the three choices!)
Example 3: Other
If they input anything else:
Are you an administrator, teacher, or student?: secretary
This should be the output:
You can only be an administrator, teacher, or student!
РЕШИТЕ ЗАДАЧУ ПО ИНФОРМАТИКЕ В excel
Во время каникул Незнайка решил поработать продавцом газет и проработал целую неделю. За каждый проданный экземпляр газеты «Известия Цветочного города» он получал 10 монет. За каждый экземпляр «Технической газеты Винтика и Шпунтика» — 7 монет. За каждый экземпляр «Медицинских новостей доктора Медуницы» — 8 монет. В понедельник он продал 8 экземпляров Известий, 7 экземпляров Технической газеты и 5 экземпляров Медицинских новостей. Во вторник было продано 13 экземпляров Известий, 4 экземпляра Технической газеты и 8 экземпляров Новостей. В среду — 10 Известий, 10 Технических и 12 Новостей. В четверг — 8 Известий, 7 Технических газет и 15 Медицинских новостей. В пятницу — 10 штук Известий, 5 штук Технических и 8 штук Медицинских. В субботу — 9 Известий, 13 Технических газет и 8 Медицинских новостей. В воскресенье — 5 экземпляров Известий, 6 экземпляров Технической и 9 экземпляров Медицинской.
Сколько экземпляров каждой газеты Незнайка продавал за каждый день недели и сколько — за всю неделю; сколько денег он зарабатывал за каждый день недели и сколько — за всю неделю; сколько денег он получал за продажу каждой газеты за всю неделю?
КАКУЮ ФОРМУЛУ НАДО ПИСАТЬ В ПУСТЫХ ЯЧЕЙКАХ? (Знаю, что должна быть формула Сумма произведений) ПИШИТЕ ФОРМУЛУ ПОДРОБНО, ПОЖАЛУЙСТА
Пацаны срочно будет ли звуковой сигнал загрузки биос без видеоядра?
Що таке «висловлювання» в інформатиці?a.
Це думка, яку може висловлювати людина
b.
Це речення, яке містить твердження про певний об’єкт або про зв’язки між об’єктами
c.
Фрагмент алгоритму, який містить послідовність команд, яка виконуватиметься вказану кількість разів
d.
Алгоритм, який обирає сценарій роботи в залежності від умови
Сместиться на (—12,16) Повтори 4 раза Сместиться на (а, Ъ) Сместиться на (—3,1) Сместиться на (2, —2) конец
Дан целочисленный массив . Найти индекс максимального элемента.
Задача по После выполнения программы, записанной на языке Pascal на экран будет выведено: program prim; var s:integer; begin s:=15; write(‘s:=‘,s/3); end. 1) s:=15 2) s=45 3)’s=‘15 4)s= 5 для школьников 5 - 9 класс? Читайте обсуждения и ответы на тему Информатика. Ответы на этот вопрос уже есть. Присоединяйтесь к нам, задавайте вопросы и делитесь своими знаниями с другими участниками.
Ответ:
1
Объяснение:
То что в ‘ , то и выводится