Блог для маленьких школьников и их родителей
ШколаЛа
26
Ноябрь

Помогите пожалуйста! 1. Напишите программу на языке Паскаль, которая позволяет найти минимальное число…

Автор: treleaggvp
Предмет: Информатика
Уровень: 5 - 9 класс

Помогите пожалуйста!

1. Напишите программу на языке Паскаль, которая позволяет найти минимальное число массива Х, состоящего из 30 элементов.

2. Напишите программу на языке Паскаль, которая позволяет найти сумму чисел массива Х, состоящего из 20 элементов.

Ответов к вопросу: 1
  • alikorol0808
    26.11.2024 | 23:17

    1.
    program MinElement;

    var

    X: array[1.30] of Integer;

    i, min: integer;

    begin
    randomize;

    for i := 1 to 30 do
    X[i] := random(100);

    min := X[1];

    for i := 1 to 30 do
    if X[i] < min then
    min := X[i];

    writeln(‘Минимальное число: ‘, min);

    write(‘Все элементы:’);

    for i := 1 to 30 do
    write(‘ ‘, X[i]);

    readln;
    end.

    2.
    program Summa;

    var

    X: array[1.20] of Integer;

    i, sum: integer;

    begin
    randomize;

    for i := 1 to 20 do
    X[i] := random(100);

    sum := 0;

    for i := 1 to 20 do
    sum := sum + X[i];  

    writeln(‘Сумма всех чисел: ‘, sum);

    write(‘Все элементы:’);

    for i := 1 to 20 do
    write(‘ ‘, X[i]);

    readln;
    end.

    Всё правильно и проверено лично!

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Задача по Помогите пожалуйста! 1. Напишите программу на языке Паскаль, которая позволяет найти минимальное число массива Х, состоящего из 30 элементов. 2. Напишите программу на языке Паскаль, которая позволяет найти сумму чисел массива Х, состоящего из 20 элементов. для школьников 5 - 9 класс. Узнайте решение и получите подробное объяснение по теме Информатика. Ответы на этот вопрос уже опубликованы. Не забывайте, что вы можете задать вопрос или поделиться собственным решением, став экспертом для других!