Написать программу для посчета всех отрицательных элементов массива. информатика, помогите плжалуйста
написать программу для посчета всех отрицательных элементов массива.
информатика, помогите плжалуйста
Помогите! Нужно написать программу в С++. Которая ищет первый столбец прямоугольной матрицы без отрицательных элементов.
Нужна помощь с задачей по Помогите! Нужно написать программу в С++. Которая ищет первый столбец прямоугольной матрицы без отрицательных элементов. ? Получите подробные решения и обсуждения от других участников для школьников 5 - 9 класс. Ответы на этот вопрос уже добавлены. Мы приглашаем вас задать свой вопрос и стать экспертом для других.
Выведем номер первого столбца матрицы a[n][m], не содержащего отрицательных элементов, или -1, если такого столбца не существует.
Код#include <bits/stdc++.h>
using namespace std;
int main() {
int n, m;
cin >> n >> m;
int a[n][m];
for (int i = 0; i < n; ++i)
for (int j = 0; j < m; ++j)
cin >> a[i][j];
for (int j = 0; j < m; ++j) {
bool b = 1;
for (int i = 0; i < n && b; ++i)
b = (a[i][j] >= 0);
if (b) {
cout << (j+1) << endl;
return 0;
}
}
cout << -1 << endl;
return 0;
}