Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами…
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.Если существует такой треугольник, то определите его тип (равносторонний, равнобедренный, разносторонний)
Пример входных данный Пример выходных данных
a b c>> 1 2 1 Не существует a b c>> 2 2 2 Равносторонний
a b c>> 20 20 30 Равнобедренный
a b c>> 3 4 5 Разносторонний
1
что не правильно в моей программе?
program qq;
var a,b,c: integer;
begin
Read (a,b,c);
if (a<>b) and (a<>c) and (c<>b) then
Write (‘Треугольник-разносторонний’);
if (a=b) or (a=c) or (c=b) then
Write (‘Треугольник-равнобедренный’);
if (a=b) and (a=c) and (c=b) then
Write (‘Треугольник-равносторонний’);
if (a
Write (‘Треугольник-не существует’);
end.
Ответ:
1.
алг
нач
цел н
вывод «Введите номер месяца »
ввод н
если н<1 или н>12 то
вывод «Месяца с таким номером не существует»
иначе
если н<6 и н>2 то вывод «Весна» все
если н<9 и н>5 то вывод «Лето» все
если н<12 и н>8 то вывод «Осень» все
если н=12 или н=1 или н=2 то вывод «Зима» все
все
кон
2.
алг
нач
цел a,b,c
вывод «Введите стороны треугольника»,нс
вывод «a = »
ввод a
вывод «b = »
ввод b
вывод «c = »
ввод c
если a+b>c и b+c>a и c+a>b то
вывод «Треугольник со сторонами «,a,»,»,b,»,»,c,» — существует»
иначе
вывод «Треугольник со сторонами «,a,»,»,b,»,»,c,» — не существует»
все
кон