Блог для маленьких школьников и их родителей
ШколаЛа
31
Май

ПОМОГИТЕ СРОЧНО! ДАЮ 100 БАЛЛОВ Напишите программу вычисления выражения в программе Паскаль АБС y =…

Автор: lp900354
Предмет: Информатика
Уровень: 10 - 11 класс

ПОМОГИТЕ СРОЧНО! ДАЮ 100 БАЛЛОВ

Напишите программу вычисления выражения в программе Паскаль АБС

y = x^4 — 3x^3 + 5x — 6

Ответов к вопросу: 2
  • map05
    31.05.2024 | 21:05

    Ответ:
    program expression;

    var

     x, y: real;

    begin

     read(x);

     y := power(x, 4) — 3 * power(x, 3) + 5 * x — 6;

     write(y);

    end.
    Объяснение:
    program expression;  // Название программы
    var

     x, y: real;  // Две переменные являются вещественными (требуется для power)
    begin  // Начало программы
     read(x);  // Вводим число с клавиатуры
     y := power(x, 4) — 3 * power(x, 3) + 5 * x — 6;  // Само выражение
    power(число, которое нужно возвести в степень | сама степень)
    power(x, 4)
    x — число
    4 — степень
     write(y);  // Выводим ответ
    end. // Начало программы

  • sashasokoliki00
    31.05.2024 | 21:24

    ##
    var x := ReadReal;
    var y := -6 + x * (5 + x * (0 + x * (-3 + x))); // схема Горнера
    Print(y)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Задача по ПОМОГИТЕ СРОЧНО! ДАЮ 100 БАЛЛОВ Напишите программу вычисления выражения в программе Паскаль АБС y = x^4 - 3x^3 + 5x - 6 для школьников 10 - 11 класс? Читайте обсуждения и ответы на тему Информатика. Ответы на этот вопрос уже есть. Присоединяйтесь к нам, задавайте вопросы и делитесь своими знаниями с другими участниками.