1. Базовая алгоритмическая структура разветвления в языке Паскаль — … Вставьте пропущенные слова. 2….
1. Базовая алгоритмическая структура
разветвления в языке Паскаль — …
Вставьте пропущенные слова.
2. Какие операторы записаны без ошибок?
А) If a> 0 Then x := a Else y: = b;
Б) If a> 0 Then x = a; Else y = b;
В) If a> 0 Then x = a; Writeln (x) else y =
b; Writeln (y)
3. Какое значение будет предоставлено
переменной x в результате выполнения
оператора
If a> 0 Then x: = a + 1 Else x: = 2 * a;
Если значение переменной a равнo 5;
A) -15;
B) 6;
D) 10?
4. Составьте программу, которая
спрашивает пользователя, который час, и
выводит на экран соответствующее
пожелание — «Доброе утро!»,
«Здравствуйте!», «Добрый вечер!» или
«Доброй ночи!». Для каждого пожелания
.выберите соответствующий цвет.
5 Компьютер должен перемножить два
числа — 167 и 121. Если их произведение
превышает 2000, то компьютер должен
напечатать текст ПРОИЗВЕДЕНИЕ
БОЛЬШОЕ, иначе текст ПРОИЗВЕДЕНИЕ
МАЛЕНЬКОЕ. После этого компьютер в
любом случае должен напечатать само
произведение.

 
  
 
















 
  
 
1)
var
a, b: integer;
begin
Readln(a, b) ;
Writeln(‘Сумма ‘, a + b, ‘; ‘, ‘Разность ‘, a — b, ‘; ‘, ‘Произведение ‘, a * b, ‘; ‘, ‘Частное ‘, a / b);
end.