Блог для маленьких школьников и их родителей
ШколаЛа
22
Ноябрь

Питон Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых…

Автор: Vika100dgf
Предмет: Информатика
Уровень: студенческий

Питон

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные

Входная строка содержит одно натуральное число.

Выходные данные

Программа должна вывести слово ‘YES’, если в числе есть две одинаковые цифры, стоящие рядом, и слово ‘NO’, если такой пары цифр нет.

Примеры

входные данные

5221

выходные данные

YES

входные данные

1232

выходные данные

NO

Ответов к вопросу: 1
  • nakoneshnaya
    22.11.2024 | 21:31

    Надеюсь, правильно.

    a = input()
    c = 0
    for b in range(len(a)):
       if b < len(a) — 1:
           if a[b] == a[b + 1]:
               c = 1
    if c == 1:
       print(‘YES’)
    else:
       print(‘NO’)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Решение задачи по Питон Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет. Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO для школьников студенческий. Прочитайте ответы, обсуждения и советы от других участников. Ответы на этот вопрос уже есть. Задавайте свои вопросы, получайте помощь и становитесь экспертом, помогая другим.