Дана матрица F(m*m)заменить нулями главную диагональ матрицы В С++ basic visual
Дана матрица F(m*m)заменить нулями главную диагональ матрицы В С++ basic visual
 
  
   
 















Дана матрица X(m,m). Запомнить в массиве Z положительные элементы главной диагонали написать программу на c++
Дана матрица F(m*m)заменить нулями главную диагональ матрицы В С++ basic visual
1.Написать программу, заполняющую квадратный массив по следующему правилу:
Элементы, стоящие на главной диагонали равны 1, ниже главной диагонали — 0, выше — 2.
2. Написать программу, которая вычисляет количество ненулевых элементов побочной диагонали
ЗАРАНЕЕ СПАСИБО)))
Задан двумерный целочисленный массив В из n строк и m столбцов (1 ≤ n, m ≤ 10).
Составить программу, которая организует двумерный массив, элементы главной
диагонали которого равны соответствующим элементам исходного массива, а остальные
элементы равны нулю.
Дан двумерный массив целых чисел.
 а) Составить программу, определяющую, верно ли, что сумма элементов
 строки массива с известным номером оканчивается цифрой 0.
 ПОЖАЛУЙСТА СРОЧНО! МОЖНО ЧЕРЕЗ С++ И ПОЛНОСТЬЮ КОД, ДАМ 20 БАЛЛОВ
Дан целочисленный массив В[1.5, 1.5]. Найти сумму элементов его правой диагонали и произведение элементов левой диагонали.Написать В С++ Срочно
НАПИСАТЬ ПРОГРАММУ В dev-c++ Составить программу, формирующую одномерный массив, состоящий из N целых элементов. Вычислить сумму положительных элеменnов массива. Определить количество элементов, имеющих четные порядковые номера и являющиеся нечетными числами. Упорядочить элементы массива по возрастанию.
на С++ Дано матрицю А розміром 6х7. Для кожного рядка матриці обчислити суму елементів, значення яких перевищує задане число С-18.6.
Составьте програму вычисления корней квадратного уравнения. С++
#include
#include
using namespace std;
int main () {
double x, y;
cout > x;
cin >> y;
if (((x -(-1)) && (y > -0) && (y -(-1)) && (x * x + y * y)) || ((x > -0) && (x -0) && (y -(-1))))
{
cout << «Success»;
}
else {
cout << «Faill»;
}
return 0;
}
fatal error LNK1169: обнаружен многократно определенный символ — один или более
непонимаю в чём проблема
Срочно.заданный одномерный массив А (8). Найти количество положительных элементов массива. С++
40 балов
Помогите решить. Надо написать на языке паскаль 7 вариант
Скільки разів буде виконано цикл
 for x in range (5, -2, -2) ?
 1) 7
 2) 4
 3) 5
 4) жодного разу
Артур составляет 5-буквенные коды из букв А, П, О, Р, Т. Каждую букву нужно использовать ровно один раз, при этом нельзя ставить рядом две гласные. Сколько различных кодов может составить Артур?
Напишите с объяснением, пожалуйста
Решите задачу.
У исполнителя имеется две команды:
1. Прибавить 3
2. Отнять 1
Какое минимальное количество команд необходимо выполнить исполнителю для получения числа 9 из числа 2 Выберите один ответ:
a.5
b.2
c.7
d.3
Write a program that lets you know if you can have a key or not, based on your role at the school.
First ask for the user’s role at the school. They can be a student, administrator, or a teacher. (And remember that capitalization is important! ‘Student’ is not the same as ‘student’.)
Example 1: Administrator or Teacher
For example, if this was the input:
Are you an administrator, teacher, or student?: teacher
This should be the output:
Administrators and teachers get keys!
Example 2: Student
And if this was the input:
Are you an administrator, teacher, or student?: student
This should be the output:
Students do not get keys!
(Note: You should also be able to handle a situation where the user enters a value other than administrator, teacher or student and tell them they must be one of the three choices!)
Example 3: Other
If they input anything else:
Are you an administrator, teacher, or student?: secretary
This should be the output:
You can only be an administrator, teacher, or student!
РЕШИТЕ ЗАДАЧУ ПО ИНФОРМАТИКЕ В excel
Во время каникул Незнайка решил поработать продавцом газет и проработал целую неделю. За каждый проданный экземпляр газеты «Известия Цветочного города» он получал 10 монет. За каждый экземпляр «Технической газеты Винтика и Шпунтика» — 7 монет. За каждый экземпляр «Медицинских новостей доктора Медуницы» — 8 монет. В понедельник он продал 8 экземпляров Известий, 7 экземпляров Технической газеты и 5 экземпляров Медицинских новостей. Во вторник было продано 13 экземпляров Известий, 4 экземпляра Технической газеты и 8 экземпляров Новостей. В среду — 10 Известий, 10 Технических и 12 Новостей. В четверг — 8 Известий, 7 Технических газет и 15 Медицинских новостей. В пятницу — 10 штук Известий, 5 штук Технических и 8 штук Медицинских. В субботу — 9 Известий, 13 Технических газет и 8 Медицинских новостей. В воскресенье — 5 экземпляров Известий, 6 экземпляров Технической и 9 экземпляров Медицинской.
Сколько экземпляров каждой газеты Незнайка продавал за каждый день недели и сколько — за всю неделю; сколько денег он зарабатывал за каждый день недели и сколько — за всю неделю; сколько денег он получал за продажу каждой газеты за всю неделю?
КАКУЮ ФОРМУЛУ НАДО ПИСАТЬ В ПУСТЫХ ЯЧЕЙКАХ? (Знаю, что должна быть формула Сумма произведений) ПИШИТЕ ФОРМУЛУ ПОДРОБНО, ПОЖАЛУЙСТА
Пацаны срочно будет ли звуковой сигнал загрузки биос без видеоядра?
Що таке «висловлювання» в інформатиці?a.
Це думка, яку може висловлювати людина
b.
Це речення, яке містить твердження про певний об’єкт або про зв’язки між об’єктами
c.
Фрагмент алгоритму, який містить послідовність команд, яка виконуватиметься вказану кількість разів
d.
Алгоритм, який обирає сценарій роботи в залежності від умови
Сместиться на (—12,16) Повтори 4 раза Сместиться на (а, Ъ) Сместиться на (—3,1) Сместиться на (2, —2) конец
Дан целочисленный массив . Найти индекс максимального элемента.
Задача по Дана матрица X(m,m). Запомнить в массиве Z положительные элементы главной диагонали написать программу на c++ для школьников студенческий. Узнайте подробное решение и обсудите его с другими участниками. Ответы на этот вопрос уже добавлены. Здесь можно не только получить помощь, но и стать экспертом, помогая другим пользователям.
#include <iostream>
#include <ctime>
using namespace std;
int** get_matrix(int rows,int columns) //Создание матрицы
{
int** matrix = new int*[rows];
for(int i = 0;i<rows;i++)
{
matrix[i] = new int[columns];
}
return matrix;
}
void fill_matrix(int** matrix, int rows,int columns, int min = -100, int max = 200)//Заполнение матрицы случайными значениями в заданном диапазоне
{
srand(time(NULL));
for(int i = 0;i<rows;i++)
{
for(int j = 0;j<columns;j++)
{
matrix[i][j] = rand() % max + min;
}
}
}
int get_count_of_positive_numbers(int** matrix, int rows, int columns)
{
int count = 0;
for(int i = 0;i<rows;i++)
{
for(int j = 0;j<columns;j++)
{
if(i == j && matrix[i][j] > 0)
count++;
}
}
return count;
}
int *get_array_of_positive_numbers(int** matrix, int rows,int columns,int count)
{
int *array = new int[count];
int x = 0;
for(int i = 0;i<rows;i++)
{
for(int j = 0;j<columns;j++)
{
if(i == j && matrix[i][j] > 0)
array[x++] = matrix[i][j];
}
}
return array;
}
int main(int argc, char** argv) {
int rows = 5;
int columns = 5;
int** matrix = get_matrix(rows,columns);//Создаем матрицу
fill_matrix(matrix,rows,columns);//Заполняем ее случайными значениями
for(int i = 0;i<rows;i++)
{
for(int j = 0;j<columns;j++)
{
cout << matrix[i][j] << «t»;
}
cout<<endl;
}
int count_of_positive_numbers = get_count_of_positive_numbers(matrix,rows,columns); //Получаем количество положительных элементов в главной диагонали
int* positive_numbers = get_array_of_positive_numbers(matrix,rows,columns,count_of_positive_numbers);//Получаем массив с этими элементами
for(int i = 0;i<count_of_positive_numbers;i++)
{
cout << positive_numbers[i] <<«t»;
}
//Очищение памяти
for(int i = 0;i<rows;i++)
{
delete[]matrix[i];
}
delete[]matrix;
delete[]positive_numbers;
return 0;
}