Блог для маленьких школьников и их родителей
ШколаЛа
18
Июнь

Помогите с информатикой! Определите количество принадлежащих отрезку [251763; 514827] натуральных чисел,…

Автор: Juliaa667
Предмет: Информатика
Уровень: студенческий

Помогите с информатикой!

Определите количество принадлежащих отрезку [251763; 514827] натуральных чисел, которые делятся без остатка на сумму своих цифр, и наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число.

Нужно написать на паскале

Ответов к вопросу: 1
  • alisa8354
    18.06.2024 | 17:42

    Ответ:
    k=0

    s=0

    mn=514828

    for i in range(251763,514827):

       a=str(i)

       for j in range(0,len(a)):

           s=s+int(a[j])

       if i%s==0:

           s=0

           k+=1

           if mn>i:

               mn=i

       else:

           s=0

    print(k,mn)

           

    Объяснение:
    питон

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Ищете решение задачи по Помогите с информатикой! Определите количество принадлежащих отрезку [251763; 514827] натуральных чисел, которые делятся без остатка на сумму своих цифр, и наименьшее из таких чисел. В ответе запишите два целых числа: сначала количество, затем наименьшее число. Нужно написать на паскале? Узнайте, как решить задачу для школьников студенческий, и читайте обсуждения на тему Информатика. Ответы уже доступны. Задавайте свои вопросы и становитесь частью нашего сообщества экспертов!