Дан двумерный массив n*m заполненный случайным образом заменить элементы последней строки на элементы…
Дан двумерный массив n*m заполненный случайным образом заменить элементы последней строки на элементы 3 строки. 
 
  
   
 















Задан двумерный целочисленный массив В из n строк и m столбцов (1 ≤ n, m ≤ 10).
Составить программу, которая организует двумерный массив, элементы главной
диагонали которого равны соответствующим элементам исходного массива, а остальные
элементы равны нулю.
Ищете помощь с задачей по Задан двумерный целочисленный массив В из n строк и m столбцов (1 ≤ n, m ≤ 10). Составить программу, которая организует двумерный массив, элементы главной диагонали которого равны соответствующим элементам исходного массива, а остальные элементы равны нулю. ? Узнайте, как решить задачу для школьников 5 - 9 класс и читайте обсуждения от других участников. Ответы уже опубликованы. Не забывайте, что вы можете задать свой вопрос или стать экспертом, помогая другим пользователям.
const n=6; m=n;
var b:array[1.n,1.m] of integer;
i,j: integer;
begin
writeln(‘Исходный массив:’);
for i:=1 to n do
begin
for j:=1 to m do
begin
b[i,j]:=random(90)+10;
write(b[i,j]:4);
end;
writeln;
end;
writeln(‘Полученный массив:’);
for i:=1 to n do
for j:=1 to m do
if i<>j then b[i,j]:=0;
for i:=1 to n do
begin
for j:=1 to m do write(b[i,j]:4);
writeln;
end;
end.
Пример:
Исходный массив:
59 63 74 85 64 87
59 86 48 66 68 44
49 36 90 15 96 34
44 52 81 83 57 53
61 45 93 85 16 40
17 68 11 43 84 96
Полученный массив:
59 0 0 0 0 0
0 86 0 0 0 0
0 0 90 0 0 0
0 0 0 83 0 0
0 0 0 0 16 0
0 0 0 0 0 96