Блог для маленьких школьников и их родителей
ШколаЛа
16
Август

Напишите программу в Питоне, которая в последовательности натуральных чисел определяет сумму чисел,…

Автор: DmitriiNevajno228
Предмет: Информатика
Уровень: 5 - 9 класс

Напишите программу в Питоне, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.

Ответов к вопросу: 2
  • Danila228465
    16.08.2024 | 21:52

    print(sum([i for i in [int(input()) for _ in range(int(input()))] if i % 6 == 0]))

  • tata111213
    16.08.2024 | 22:05

    Ответ:
    — Python 3.7.0 —

    def ReadSeq(SeqLen: int, CastType):

      for _ in range(SeqLen):

          yield CastType(input())

    def main():

       RawSequence = ReadSeq(int(input()), int)

       Selector = lambda item: (item % 6 == 0)

       FilteredSequence = filter(Selector, RawSequence)

       print(f’Res: {sum( list( FilteredSequence ) )}’)

    if __name__ == «__main__»:

       main()

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Ответы на задачу по Напишите программу в Питоне, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6. для школьников 5 - 9 класс. Узнайте решение и читайте обсуждения по предмету Информатика. Ответы на этот вопрос уже добавлены. Наш сайт предлагает вам возможность стать экспертом и помогать другим.