Блог для маленьких школьников и их родителей
ШколаЛа
08
Сентябрь

9 класс фастом Написать программу, заполняющую массив 30 случайными числами [-10.80]. Вывести массив. Определить в этом…

Автор: tamik14012007
Предмет: Информатика
Уровень: 5 - 9 класс

9 класс фастом

Написать программу, заполняющую массив 30 случайными числами [-10.80].

Вывести массив.

Определить в этом массиве сумму чисел, кратных 3

Определить количество отрицательных чисел.

Определить в этом массиве номер элемента, равного 0

Ответов к вопросу: 1
  • dashagrechko2410
    08.09.2024 | 20:26

    Var a: array [1.30] of integer;

    sum3,otr,i,j:integer;

    begin

    randomize;

    sum3:=0;

    otr:=0;

    for i:=1 to 30 do  
     begin

       a[i]:=random(91)-10;

       write(a[i]:4);

       if a[i] mod 3 = 0 then sum3:=sum3+a[i];

       if a[i]<0 then inc(otr);

     end;

     writeln;

     writeln(‘Sum: ‘,sum3,’   <0:’,otr);

     for i:=1 to 30 do

       if a[i]=0 then  
         begin

          writeln(‘№’,i,’=0′);

         end;

    end.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.