Блог для маленьких школьников и их родителей
ШколаЛа
11
Август

Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка…

Автор: nazygat35
Предмет: Информатика
Уровень: 5 - 9 класс

Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. Размер последовательности определяет сам пользователь программы. Принять, что последовательность состоит только из целых положительных чисел.

Ответов к вопросу: 2
  • temaci113
    11.08.2024 | 22:15

    //PascalABC.NET
    //Версия 3.3, сборка 1627
    begin
    var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
    write(‘кол-во чисел, делящихся на 8 без остатка: ‘,a.Count(),’; сумма: ‘,a.Sum());
    end.

  • DanayAi
    11.08.2024 | 22:26

    program qq;
    var a, b, c, d, e:integer;
    BEGIN
    d:=0;
    e:=0;
    writeln(‘Введите количество чисел’);
    readln (a);
    writeln (‘Введите числа’);
    for b:=1 to a do
    begin

    readln (c);
    if c mod 8 = 0 then
    d:=d+c;
    e:=e+1;
    end;
    Writeln (‘Количество чисел кратных восьми — ‘, e, ‘; Их сумма — ‘, d);
    END.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.