Дан фрагмент программы написанной на языке программирования Паскаль
Дан фрагмент программы написанной на языке программирования Паскаль
















Дан фрагмент программы на языке Паскаль. Определите, что будет напечатано в результате работы этой программы
m:15
n:1
repeat
m:=m-2
n:=n*2
until m<6
writeln(‘m=’,m)
writeln(‘n=’,n)
СРОЧНО! ПЛИЗЗ
Дан фрагмент программы написанной на языке программирования Паскаль
После выполнения программы, записанной на языке Pascal на экран будет выведено: program prim; var s:integer; begin s:=15; write(‘s:=‘,s/3); end. 1) s:=15 2) s=45 3)’s=‘15 4)s= 5
Написать программу на Паскале , не используя массивов
Выведи на экран все четные числа от 2 до n включительно и посчитайте их количество
Помогите . Напишите программу полностью на Паскале
Составить программу на языке Паскаль, вычисляющую сумму всех чисел, кратных 3 на интервале от 1 до n. Применить цикл с заданным числом повторений.
1. Базовая алгоритмическая структура
разветвления в языке Паскаль — …
Вставьте пропущенные слова.
2. Какие операторы записаны без ошибок?
А) If a> 0 Then x := a Else y: = b;
Б) If a> 0 Then x = a; Else y = b;
В) If a> 0 Then x = a; Writeln (x) else y =
b; Writeln (y)
3. Какое значение будет предоставлено
переменной x в результате выполнения
оператора
If a> 0 Then x: = a + 1 Else x: = 2 * a;
Если значение переменной a равнo 5;
A) -15;
B) 6;
D) 10?
4. Составьте программу, которая
спрашивает пользователя, который час, и
выводит на экран соответствующее
пожелание — «Доброе утро!»,
«Здравствуйте!», «Добрый вечер!» или
«Доброй ночи!». Для каждого пожелания
.выберите соответствующий цвет.
5 Компьютер должен перемножить два
числа — 167 и 121. Если их произведение
превышает 2000, то компьютер должен
напечатать текст ПРОИЗВЕДЕНИЕ
БОЛЬШОЕ, иначе текст ПРОИЗВЕДЕНИЕ
МАЛЕНЬКОЕ. После этого компьютер в
любом случае должен напечатать само
произведение.
ЯЗЫК: Pascal
Const n=5; m=4;
var s, i, j : integer;
a: array [1.n, 1.m] of
integer;
begin
for i:= 1 to n do
for j:= 1 to m do
a[i,j]:=random(10);
for i:=1 to n do begin
for j:=1 to m do
write ( A[i,j]:5 );
writeln;
end;
S:=0;
For i:=1 to n do
For j:=1 to m do
S:=S+a[i,j];
Writeln(‘сумма элементов
массива равна ‘,S);
end.
Изменить программу таким образом, чтобы:
a. Матрица состояла из 15 элементов вещественного типа;
b. Значения элементов должны меняться в интервале от 3 до 7;
c. В результате выполнения программы должно быть найдено
произведение всех элементов матрицы;
d. Вычисляться сумма элементов матрицы по строкам.
Напишите программу на языке паскаль
Запрограммировать решение задач на языке Паскаль.
1) Программа предлагает вычислить выражение 12*6 — 13*3 и ввести ответ с клавиатуры. Если ответ верен, то вывести на экран фразу «Правильно!», иначе — вывести «Ошибка в расчётах!» 2) Программа запрашивает возраст. Если введён воздаст до 14 лет, то программа выводит «Вы ещё не получили паспорт!, иначе — программа выводит «Пасторт вами получен!». 3*) Составьте программу «Покупка». В магазине продают три вида мороженого: Эскимо по цене 50 рублей, фруктовый лёд по цене 30 рублей и пломбир по цене 48 рублей. Программа запращивает «Какое мороженое хотите купить?». Пользователь вводит название сорта мороженого. В ответ на экран выводится стоимость мороженого.
Написать программу на языке программирования Паскаль
1. Найти разность, сумму и произведение двух значений переменных.
2. Ввести два числа. Вычесть из большего меньшее.
Помогите решить. Надо написать на языке паскаль 7 вариант
Скільки разів буде виконано цикл
for x in range (5, -2, -2) ?
1) 7
2) 4
3) 5
4) жодного разу
Артур составляет 5-буквенные коды из букв А, П, О, Р, Т. Каждую букву нужно использовать ровно один раз, при этом нельзя ставить рядом две гласные. Сколько различных кодов может составить Артур?
Напишите с объяснением, пожалуйста
Решите задачу.
У исполнителя имеется две команды:
1. Прибавить 3
2. Отнять 1
Какое минимальное количество команд необходимо выполнить исполнителю для получения числа 9 из числа 2 Выберите один ответ:
a.5
b.2
c.7
d.3
Write a program that lets you know if you can have a key or not, based on your role at the school.
First ask for the user’s role at the school. They can be a student, administrator, or a teacher. (And remember that capitalization is important! ‘Student’ is not the same as ‘student’.)
Example 1: Administrator or Teacher
For example, if this was the input:
Are you an administrator, teacher, or student?: teacher
This should be the output:
Administrators and teachers get keys!
Example 2: Student
And if this was the input:
Are you an administrator, teacher, or student?: student
This should be the output:
Students do not get keys!
(Note: You should also be able to handle a situation where the user enters a value other than administrator, teacher or student and tell them they must be one of the three choices!)
Example 3: Other
If they input anything else:
Are you an administrator, teacher, or student?: secretary
This should be the output:
You can only be an administrator, teacher, or student!
РЕШИТЕ ЗАДАЧУ ПО ИНФОРМАТИКЕ В excel
Во время каникул Незнайка решил поработать продавцом газет и проработал целую неделю. За каждый проданный экземпляр газеты «Известия Цветочного города» он получал 10 монет. За каждый экземпляр «Технической газеты Винтика и Шпунтика» — 7 монет. За каждый экземпляр «Медицинских новостей доктора Медуницы» — 8 монет. В понедельник он продал 8 экземпляров Известий, 7 экземпляров Технической газеты и 5 экземпляров Медицинских новостей. Во вторник было продано 13 экземпляров Известий, 4 экземпляра Технической газеты и 8 экземпляров Новостей. В среду — 10 Известий, 10 Технических и 12 Новостей. В четверг — 8 Известий, 7 Технических газет и 15 Медицинских новостей. В пятницу — 10 штук Известий, 5 штук Технических и 8 штук Медицинских. В субботу — 9 Известий, 13 Технических газет и 8 Медицинских новостей. В воскресенье — 5 экземпляров Известий, 6 экземпляров Технической и 9 экземпляров Медицинской.
Сколько экземпляров каждой газеты Незнайка продавал за каждый день недели и сколько — за всю неделю; сколько денег он зарабатывал за каждый день недели и сколько — за всю неделю; сколько денег он получал за продажу каждой газеты за всю неделю?
КАКУЮ ФОРМУЛУ НАДО ПИСАТЬ В ПУСТЫХ ЯЧЕЙКАХ? (Знаю, что должна быть формула Сумма произведений) ПИШИТЕ ФОРМУЛУ ПОДРОБНО, ПОЖАЛУЙСТА
Пацаны срочно будет ли звуковой сигнал загрузки биос без видеоядра?
Що таке «висловлювання» в інформатиці?a.
Це думка, яку може висловлювати людина
b.
Це речення, яке містить твердження про певний об’єкт або про зв’язки між об’єктами
c.
Фрагмент алгоритму, який містить послідовність команд, яка виконуватиметься вказану кількість разів
d.
Алгоритм, який обирає сценарій роботи в залежності від умови
Сместиться на (—12,16) Повтори 4 раза Сместиться на (а, Ъ) Сместиться на (—3,1) Сместиться на (2, —2) конец
Дан целочисленный массив . Найти индекс максимального элемента.
Ответ:
m=5
n=32
Объяснение:
Это если:
m:15
n:1
на самом деле:
m:=15
n:=1
и не считая отсутствующих точек с запятой (;)
m = 15
n = 1
Действия в цикле:
1) m = m — 2
2) n = n * 2
Цикл работает пока ложно (нет) условие: m < 6
Вывод m
Вывод n
m = 15 n = 1
Действия в цикле:
1) m = m — 2 = 15 — 2 = 13
2) n = n * 2 = 1 * 2 = 2
13 < 6 (нет)
m = 13 n = 2
Действия в цикле:
1) m = m — 2 = 13 — 2 = 11
2) n = n * 2 = 2 * 2 = 4
11 < 6 (нет)
m = 11 n = 4
Действия в цикле:
1) m = m — 2 = 11 — 2 = 9
2) n = n * 2 = 4 * 2 = 8
9 < 6 (нет)
m = 9 n = 8
Действия в цикле:
1) m = m — 2 = 9 — 2 = 7
2) n = n * 2 = 8 * 2 = 16
7 < 6 (нет)
m = 7 n = 16
Действия в цикле:
1) m = m — 2 = 7 — 2 = 5
2) n = n * 2 = 16 * 2 = 32
5 < 6 (да)
Цикл прекращает работу
m = 5 n = 32
Оператор writeln выведет на экран сначала текст в кавычках без них (m=), а затем значение переменной (5).