Блог для маленьких школьников и их родителей
ШколаЛа
19
Сентябрь

Контрольная по информатике 8 класс. ПОМОГИТЕ! СРОЧНО 1 Определите значение переменной s после вы- полнения следующих…

Автор: letsg5699
Предмет: Информатика
Уровень: 5 - 9 класс

Контрольная по информатике 8 класс. ПОМОГИТЕ! СРОЧНО

1

Определите значение переменной s после вы-

полнения следующих операторов. Запишите

значения переменных и условия на каждом

шаге в виде таблицы.

а)

s:=0; i:=1;

while i<=5 do begin

s:=s*i–2

i:=i+2;

end;

б)

s:=4;

for i:=1 to 3 do s:=s*i;

в)

s:=3; j:=–2;

repeat

s:=s*j;

j:=j+1;

until j>0;

2

Используя цикл, составьте программу вычис-

ления произведения первых 5 натуральных

чисел.

Ответов к вопросу: 1
  • anaisovamila
    19.09.2024 | 21:33

    Ответ:
    а) s= -42
    б) s= 8
    в) s= 6
    Объяснение:
    1)
    а)
    i   |  1  |  3  |  5  |  7  |
    s   |  0 | -2 | -8  |-42 |  
    б)
    i  |  1  |  2  |  3  |
    s  |  4 |  4  |  8  |
    в)
    j  | -2  | -1  |  0  |
    s  |  3  | -6  |  6  |
    2) (PascalABC)
    var
    p:=1; i:integer;

    begin
    //FOR

    for i:= 1 to 5 do
     p:=p*i;

    writeln(p);

    end.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.