ДАЮ 100 БАЛЛОВ С++ Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские,…
ДАЮ 100 БАЛЛОВ
С++
Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные).
Входные данные
Входная строка содержит символы латинского алфавита, как строчные, так и заглавные.
Выходные данные
Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен.
Примеры
входные данные
aabbccabadef
выходные данные
bbbbccbbbdef
4
1)
var
S : String;
begin
readln(s);
while (Pos(‘а’, S) > 0) or (Pos(‘a’, S) > 0) do
begin
if Pos(‘а’, S) > 0 then
S[Pos(‘а’,S)] := ‘б’
else
S[Pos(‘a’, S)]:= ‘b’;
end;
writeln(S);
end.
2)
12ABC3456789