Блог для маленьких школьников и их родителей
ШколаЛа
07
Август

НА ЯЗЫКЕ ПРОГРАММИРОВАНИЯ PAYTHON!Напишите программу, которая в последовательности натуральных чисел находит среднее…

Автор: nmubinov78
Предмет: Информатика
Уровень: 5 - 9 класс

РЕШИТЬ НА ЯЗЫКЕ ПРОГРАММИРОВАНИЯ PAYTHON!Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введенные числа не превышают 300.

Ответов к вопросу: 1
  • lets1de
    07.08.2024 | 10:26

    Ответ:
    n = int(input(‘Введите натуральное число:’))

    count = 0

    numbers = []

    while count <99 and n != 0:

       if n > 300:

           print(‘Вы ввели число больше 300!’)

           break

       else:

           numbers.append(n)

           n = int(input(‘Введите натуральное число:’))

           count += 1

    summ = sum(numbers)

    average = summ / len(numbers)

    print(f’среднее арифметическое = {average}’)
    Объяснение:
    Есть нюанс, при первом вводе числа большего за 300 программа уйдет в ошибку (если нужнен отлов ошибок, нужно программу доделывать, это не просто)
    При вводе числа больше 300 вторым, третим.n-ым выведет ‘Вы ввели число больше 300’

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.