Блог для маленьких школьников и их родителей
ШколаЛа
21
Август

(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет…

Автор: valentink710
Предмет: Информатика
Уровень: 10 - 11 класс

(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. (НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON)

Ответов к вопросу: 1
  • djdhdgdhdh
    21.08.2024 | 23:01

    summ = 0

    a = int(input())

    while a != 0:

       if a % 7 == 0 and a % 10 == 2:

           summ += a

       a = int(input())

    print(summ)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.