Блог для маленьких школьников и их родителей
ШколаЛа
13
Декабрь

На паскале скринн всего экрана Задача А. С клавиатуры вводится натуральное число. Напишите программу,…

Автор: MaximTipson
Предмет: Информатика
Уровень: студенческий

на паскале скринн всего экрана

Задача А. С клавиатуры вводится натуральное число. Напишите программу, которая выводит “ДА”, если число четное, иначе — “НЕТ”.

Задача Б. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе — произведение. После этого компьютер должен напечатать результат

Ответов к вопросу: 1
  • Egorka252222
    13.12.2024 | 08:36

    Ответ:
    ~~~~~~~~~~
    А)
    program num;
    var

     number: integer;
    begin
     read(number);
     if (number mod 2 = 0) then
       write(‘ДА’)
     else
       write(‘НЕТ’);
    end.
    ~~~~~~~~~~
    Б)
    program b;
    var

     first, second: integer;
    begin
     read(first, second);
     if (first > second) then
       write(first + second)
     else
       write(first * second);
    end.
    ~~~~~~~~~~
    Объяснение:
    ~~~~~~~~~~
    А)
    program num; // Название программы

    var

     number: integer; // Целочисленная переменная, хранящая вводимое с клавиатуры число

    begin // Начало программы

     read(number); // Считываем число с клавиатуры

     if (number mod 2 = 0) then // Если остаток от деления значения переменной number на 2 = 0, тогда

       write(‘ДА’) // Выводим «Да»

     else // Иначе

       write(‘НЕТ’); // Выводим «Нет»

    end. // Конец  программы
    ~~~~~~~~~~
    Б)
    program b; // Название программы

    var

     first, second: integer; // Целочисленные переменные, хранящие вводимые с клавиатуры числа

    begin // Начало программы

     read(first, second); // Считываем числа с клавиатуры

     if (first > second) then // Если первое число > второго числа, тогда

       write(first + second) // Выводим сумму этих чисел

     else // Иначе

       write(first * second); // Выводим произведение этих чисел

    end. // Конец  программы
    ~~~~~~~~~~

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Ищете решение задачи по на паскале скринн всего экрана Задача А. С клавиатуры вводится натуральное число. Напишите программу, которая выводит “ДА”, если число четное, иначе - “НЕТ”. Задача Б. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение. После этого компьютер должен напечатать результат для студенческий? На странице вы найдете не только подробное объяснение задачи, но и обсуждения от других участников. Ответы на этот вопрос уже добавлены. Этот вопрос относится к Информатика, и помогает разобраться в теме на паскале скринн всего экрана Задача А. С клавиатуры вводится натуральное число. Напишите программу, которая выводит “ДА”, если число четное, иначе - “НЕТ”. Задача Б. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение. После этого компьютер должен напечатать результат. На нашем сайте вы можете задать собственный вопрос и получить помощь от опытных экспертов.