Написать программу Pascal
Написать программу Pascal
















Напишите программу на языке Pascal для следующей задачи: Определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа K, т.е. число K вводится с клавиатуры
Задача по Напишите программу на языке Pascal для следующей задачи: Определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа K, т.е. число K вводится с клавиатуры для школьников 5 - 9 класс? Здесь вы найдете ответы на вопрос, обсуждения и полезные рекомендации по предмету Информатика. Ответы на этот вопрос уже добавлены. Присоединяйтесь к нашему сообществу, задавайте вопросы и становитесь экспертом!
//программа определит максимальное n
program qwerty;
var a, k, sum:integer;
begin
readln(k);
a:=1;
while((sum+a*a)<=k) do begin
sum:=sum+a*a;
a:=a+1;
end;
writeln(a-1);
end.