Определить значение переменной Y в результате выполнения фрагмента программы y =1; i =0; k =2; for (int…
Определить значение переменной Y в результате выполнения фрагмента программы
y =1; i =0; k =2; for (int i = 1; i <= 6; i ++) y = k * y;
(c++)
















Проанализируйте работу программы
program math;
var x, y: integer;
begin
x:=1; y:=1;
while x<7 do
begin
у:=y*2;
x:=x+1
end;
end.
Ответьте на вопросы:
а) Сколько раз исполнится тело цикла?
б) Сколько раз исполнится тело цикла, если изменить условие на х>=7?
Определить значение переменной Y в результате выполнения фрагмента программы
y =1; i =0; k =2; for (int i = 1; i <= 6; i ++) y = k * y;
(c++)
3. Определите значение переменных i, y после выполнения фрагмента программы
y = 5
i = 1
while i<=5:
i+=2
y*=2
1)Какой из заголовков циклов не содержит ошибок?
FOR X:=3 DOWNTO 12 DO
FOR J:=10 DOWNTO -2 DO
FOR K=10 DOWNTO 5 DO
FOR I:=10 DOWNTO 5.5 DO
2)Сколько раз выполнится тело цикла for i:=2 to 5 do x:=6;
3)на фото
Расположите в правильном порядке строки программы:
1) S:=a*h;
6) var a,b,h,p,s: integer;
2) end.
7) readln;
3) program pr;
Writeln(‘p=’,p,’ s=’,s);
4) p:=(a+b)^2;
9) a:=5;b:=8;h:=3;
5) begin
2. Установите соответствие между служебными словами и названиями разделов программы:
а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей
3. Определите значение переменной a после выполнения алгоритма:
а := 8
b := 2
b := a/2*b
a := 2*а + 3*b
В ответе укажите одно целое число — значение переменной a.
4.Запишите значение переменной y, полученное в результате работы следующей программы.
var y, i: integer;
begin
y := 0;
for i := 1 to 3 do
y := y + 4 * i;
writeln(y);
end.
5.Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.
var t, i: integer;
begin
t := 2;
for i := 1 to 3 do
t := t * i;
writeln(t);
end.
скільки разів виконається тіло циклу у наступному фрагменті програми? s=1 n=10 while n=10 s=s+2
Відповіді:
жодого разу
1 раз
5 раз
безліч разів
CРОЧНО НАДО ПАСКАЛЬ! ПО-БЫСТРОМУ!
Цикл с параметром. Урок 1
8 Задание
Определи результат переменной s после выполнения кода программы.
s=1
x=2
for y in range(4):
s=math.pow(x,y)
4
16
8
6
Помогите решить.
1. В результате выполнения следующих операторов:
a:=3;
b:=4;
x:=sqrt(sqr(a) +sqr(b);
Write(‘ x= ‘ ,x, ‘ a+b=7 ‘);
Writeln(a, b,’a’, ‘b’);
Будет напечатано:
Д) x= 5true 34ab
E) x= 5 a+b=7 34ab
Ж) x=sqrt(sqr(a) +sqr(b)), a+b=7 34ab
З) x= 5.00000000000000E+0000 true 34ab
2. Определите значение целочисленной переменной a после выполнения фрагмента алгоритма:
a:=247;
b:=(a div 100)*10+9;
a:=(10*b-a) mod 10;
3. Укажите значение для переменных x и y после выполнения операторов:
x:=2;
y:=5;
x:=y;
y:=x;
4. Какую задачу решает данная программа?
program primer;
car a, b, c : integer;
begin
writeln(‘введите двузначное число’);
readln(a);
b:=a div 10;
c:=a mod 10;
write(c*10+b);
end.
Д) находит сумму цифр числа;
Е) вычисляет целую часть и остаток от деления на 10;
Ж) меняет цифры числа местами;
З) находит цифры числа, а на экран выводит само число.
5. Среди предложенных выражений выберите логические
И) (x=3)or (x<>4)
К) 2*x+5
Л) x mod 2 = 0
М) x div 3
Н) x+y = 10
0) x+y
П) (x+y>5) or (x-y>5)
Р) (x>3) and (x<=10)
Скільки разів буде виконуватися тіло циклу For I:=7 To 8 Do —
For I:=8 To 7 Do —
For I:=0 To 0 Do —
For I:=1 To 5 Do-
15. Сколько раз будут выполнены операторы внутри цикла в следующем фрагменте
х = 2; у =10,
while y- x> 1 do begin
x = x+ 1 y = y-1, end
sum:= x+ y;
Cкільки разів виконається цикл: x:=15; while x>=10 do x:=x-3; *
Помогите решить. Надо написать на языке паскаль 7 вариант
Скільки разів буде виконано цикл
for x in range (5, -2, -2) ?
1) 7
2) 4
3) 5
4) жодного разу
Артур составляет 5-буквенные коды из букв А, П, О, Р, Т. Каждую букву нужно использовать ровно один раз, при этом нельзя ставить рядом две гласные. Сколько различных кодов может составить Артур?
Напишите с объяснением, пожалуйста
Решите задачу.
У исполнителя имеется две команды:
1. Прибавить 3
2. Отнять 1
Какое минимальное количество команд необходимо выполнить исполнителю для получения числа 9 из числа 2 Выберите один ответ:
a.5
b.2
c.7
d.3
Write a program that lets you know if you can have a key or not, based on your role at the school.
First ask for the user’s role at the school. They can be a student, administrator, or a teacher. (And remember that capitalization is important! ‘Student’ is not the same as ‘student’.)
Example 1: Administrator or Teacher
For example, if this was the input:
Are you an administrator, teacher, or student?: teacher
This should be the output:
Administrators and teachers get keys!
Example 2: Student
And if this was the input:
Are you an administrator, teacher, or student?: student
This should be the output:
Students do not get keys!
(Note: You should also be able to handle a situation where the user enters a value other than administrator, teacher or student and tell them they must be one of the three choices!)
Example 3: Other
If they input anything else:
Are you an administrator, teacher, or student?: secretary
This should be the output:
You can only be an administrator, teacher, or student!
РЕШИТЕ ЗАДАЧУ ПО ИНФОРМАТИКЕ В excel
Во время каникул Незнайка решил поработать продавцом газет и проработал целую неделю. За каждый проданный экземпляр газеты «Известия Цветочного города» он получал 10 монет. За каждый экземпляр «Технической газеты Винтика и Шпунтика» — 7 монет. За каждый экземпляр «Медицинских новостей доктора Медуницы» — 8 монет. В понедельник он продал 8 экземпляров Известий, 7 экземпляров Технической газеты и 5 экземпляров Медицинских новостей. Во вторник было продано 13 экземпляров Известий, 4 экземпляра Технической газеты и 8 экземпляров Новостей. В среду — 10 Известий, 10 Технических и 12 Новостей. В четверг — 8 Известий, 7 Технических газет и 15 Медицинских новостей. В пятницу — 10 штук Известий, 5 штук Технических и 8 штук Медицинских. В субботу — 9 Известий, 13 Технических газет и 8 Медицинских новостей. В воскресенье — 5 экземпляров Известий, 6 экземпляров Технической и 9 экземпляров Медицинской.
Сколько экземпляров каждой газеты Незнайка продавал за каждый день недели и сколько — за всю неделю; сколько денег он зарабатывал за каждый день недели и сколько — за всю неделю; сколько денег он получал за продажу каждой газеты за всю неделю?
КАКУЮ ФОРМУЛУ НАДО ПИСАТЬ В ПУСТЫХ ЯЧЕЙКАХ? (Знаю, что должна быть формула Сумма произведений) ПИШИТЕ ФОРМУЛУ ПОДРОБНО, ПОЖАЛУЙСТА
Пацаны срочно будет ли звуковой сигнал загрузки биос без видеоядра?
Що таке «висловлювання» в інформатиці?a.
Це думка, яку може висловлювати людина
b.
Це речення, яке містить твердження про певний об’єкт або про зв’язки між об’єктами
c.
Фрагмент алгоритму, який містить послідовність команд, яка виконуватиметься вказану кількість разів
d.
Алгоритм, який обирає сценарій роботи в залежності від умови
Сместиться на (—12,16) Повтори 4 раза Сместиться на (а, Ъ) Сместиться на (—3,1) Сместиться на (2, —2) конец
Дан целочисленный массив . Найти индекс максимального элемента.
Ответ:
а) Тело цикла исполнится 6 раз
б) Если изменить условие на х>=7, тело цикла исполнится 0 раз