Блог для маленьких школьников и их родителей
ШколаЛа
22
Сентябрь

Нужно написать программу, которая печатает true, если точка (x;y) принадлежит закрашенной области. Pascale.

Автор: anataranova156
Предмет: Информатика
Уровень: 5 - 9 класс

Нужно написать программу, которая печатает true, если точка (x;y) принадлежит закрашенной области. Pascale.

Ответов к вопросу: 1
  • redziksyu
    22.09.2024 | 11:41

    var

     x, y: real;

    begin

     read(x, y);

     if ((((y <= -x + 4) and (y >= -x + 2) and (x >= 0) and (y >= 0))  
     or ((y <= x + 4) and (y >= x + 2) and (x <= 0) and (y >= 0))  
     or ((y >= -x — 4) and (y <= -x — 2)) and (x <= 0) and (y <= 0)))then

       write(‘true’);

    end.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Задача по Нужно написать программу, которая печатает true, если точка (x;y) принадлежит закрашенной области. Pascale. для школьников 5 - 9 класс? Узнайте решение и получите советы по предмету Информатика. Прочитайте множественные ответы, чтобы разобраться в теме. Ответы уже доступны. Если у вас есть трудности, не стесняйтесь попросить помощи у экспертов. А также вы можете стать экспертом и помогать другим ученикам!