Блог для маленьких школьников и их родителей
ШколаЛа
03
Сентябрь

ДАЮ 55 БАЛЛОВ ЯЗЫК PYTHON, 10 класс: Напишите программу, которая выводит первое слово переданной её…

Автор: TheHainDit
Предмет: Информатика
Уровень: 10 - 11 класс

ДАЮ 55 БАЛЛОВ

ЯЗЫК PYTHON, 10 класс:

Напишите программу, которая выводит первое слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.

Входные данные:

Входная строка содержит произвольную последовательность символов.

Выходные данные:

Программа должна вывести первое слово этой строки.

Примеры:

Входные данные

Vasya is a pupil.

Выходные данные

Vasya

Пожалуйста:) а то у меня с python все очень-очень плохо

Ответов к вопросу: 1
  • TamiReznik
    03.09.2024 | 13:23

    a = input(«Введите строку: «)

    for i in range(len(a)):

      if a[i] == ‘ ‘ or a[i] == ‘,’ or a[i] == ‘.’ or a[i] == ‘!’ or a[i] == ‘!’ or a[i] == ‘?’ or a[i] == ‘:’:

          break

      else:

          print(a[i],end=»»)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.

Нужна помощь с задачей по ДАЮ 55 БАЛЛОВ ЯЗЫК PYTHON, 10 класс: Напишите программу, которая выводит первое слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. Входные данные: Входная строка содержит произвольную последовательность символов. Выходные данные: Программа должна вывести первое слово этой строки. Примеры: Входные данные Vasya is a pupil. Выходные данные Vasya Пожалуйста:) а то у меня с python все очень-очень плохо? Получите подробные решения и обсуждения от других участников для школьников 10 - 11 класс. Ответы на этот вопрос уже добавлены. Мы приглашаем вас задать свой вопрос и стать экспертом для других.