Блог для маленьких школьников и их родителей
ШколаЛа
14
Ноябрь

Составьте программу, которая заменяет букв на букву "б" и наоборот в данной символьной стро писанной всеми заглавными и…

Автор: dkonotop16
Предмет: Информатика
Уровень: студенческий

Составьте программу, которая заменяет букв на букву «б» и наоборот в данной символьной стро писанной всеми заглавными и строчными буквами. При вводе строки «оглваООГЛВАО» результат должен быть в виде «головаГОЛОВА».​

Ответов к вопросу: 1
  • richstog
    14.11.2024 | 22:15

    Ответ:

    def замена_букв(строка):
       результат = »
       for символ in строка:
           if символ.islower():
               результат += ‘б’
           elif символ.isupper():
               результат += ‘Б’
           else:
               результат += символ
       return результат

    входная_строка = input(«Введите строку: «)
    результат = замена_букв(входная_строка)
    print(«Результат замены:», результат)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.