Блог для маленьких школьников и их родителей
ШколаЛа
01
Декабрь

Написать программу которая по заданным координатам x и y, определяет принадлежит ли точка заштрихованной области…

Автор: daper021289
Предмет: Информатика
Уровень: 10 - 11 класс
Фото к вопросу: Написать программу которая по заданным координатам x и y…

Написать программу которая по заданным координатам x и y, определяет принадлежит ли точка заштрихованной области.

Помогите пожалуйста!

Ответов к вопросу: 1
  • khanames
    01.12.2024 | 16:40

    Program Rick_and_Morty; //название поменяй

    var x,y:integer;

    Begin
    write(‘введите x: ‘);
    readln (x);
    write(‘введите y: ‘);
    readln (y);
    if ((x<=0) and (y>=0) and (x*x+y*y<=36)) //тут условие
    or ((x<=0) and (y<=0) and (x*x+y*y<=36)) //and как и, or как или
    or ((x>=0) and (y<=0) and (x*x+y*y<=36)) // условие закончилось
    then //если хоть одно условие верно то
    writeln(‘(‘,x,’,’,y,’) — входят в облость’)
    else // если не верно то
    writeln(‘(‘,x,’,’,y,’) — не входят в облость’);

    writeln(‘конец’);
    end.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.