Блог для маленьких школьников и их родителей
ШколаЛа
28
Октябрь

Дан двумерный массив целых чисел. а) Составить программу, определяющую, верно ли, что сумма элементов строки массива с…

Автор: gulia21041981
Предмет: Информатика
Уровень: 5 - 9 класс

Дан двумерный массив целых чисел.
а) Составить программу, определяющую, верно ли, что сумма элементов
строки массива с известным номером оканчивается цифрой 0.
ПОЖАЛУЙСТА СРОЧНО! МОЖНО ЧЕРЕЗ С++ И ПОЛНОСТЬЮ КОД, ДАМ 20 БАЛЛОВ​

Ответов к вопросу: 1
  • ah14sanova13a
    28.10.2024 | 08:57

    Ответ:
    #include <iostream>

    using namespace std;

    int main()

    {

       int line, column;

       cout << «Введите количество строк и столбцов через пробел: «;

       cin >> line >> column;

       int array[50][50] = {};

       cout << «Введите элементы двумерного массива: n»;

       for (int i = 0; i < line; i++ )

       {

           for (int j = 0; j < column; j++)

           {

               cin >> array[i][j];

           }

           cout << endl;

       }

       int amount = 0;

       int line_index;

       cout << «Введите индекс строки массива: «;

       cin >> line_index;

       for (int j = 0; j < column; j++)

       {

           int i = line_index;

           amount += array[i][j];

       }

       if (amount % 10 == 0)

       {

           cout << «YES»;

       }

       else

       {

           cout << «NO»;

       }

    }

    Объяснение:
    #include <iostream>  // Библиотека ввода — вывода
    using namespace std;  // Пространство имен
    int main()

    {

       int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве
       cout << «Введите количество строк и столбцов через пробел: «;  // Вывод сообщения в консоль
       cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры
       int array[50][50] = {};  // Создание целочисленного массива размером 50х50
       cout << «Введите элементы двумерного массива: n»;  // Вывод сообщения в консоль
       for (int i = 0; i < line; i++ )  // Ввод элементов массива
       {  // Ввод элементов массива
           for (int j = 0; j < column; j++)  // Ввод элементов массива
           {  // Ввод элементов массива
               cin >> array[i][j];  // Ввод элементов массива
           }  // Ввод элементов массива
           cout << endl;  // Ввод элементов массива
       }  // Ввод элементов массива
       int amount = 0;  // Создание целочисленной переменной, хранящей сумму нужной строки
       int line_index;  // Переменная, хранящая индекс нужной строки
       cout << «Введите индекс строки массива: «;  // Вывод сообщения в консоль
       cin >> line_index;  // Ввод индекса нужной строки с клавиатуры
       for (int j = 0; j < column; j++)  // Находим все элементы нужной строки
       {

           int i = line_index;  // Нужна сумма определенной строки ⇒ значение переменной i будет постоянным
           amount += array[i][j];  // Переменная, хранящая сумму элементов нужной строки, суммируется с элементами строки
       }

       if (amount % 10 == 0)  // Если последняя цифра суммы = 0
       {

           cout << «YES»;  // Выводим «YES»
       }

       else  // Иначе
       {

           cout << «NO»;  // Выводим «NO»
       }

    }

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.