Блог для маленьких школьников и их родителей
ШколаЛа
05
Ноябрь

Напишите программу Python, которая заполняет массив из 10 элементов случайными числами на отрезке [-7; 7] и находит: a…

Автор: nadad302
Предмет: Информатика
Уровень: 5 - 9 класс

Напишите программу Python, которая заполняет массив из 10 элементов случайными числами

на отрезке [-7; 7] и находит:

a. Максимальный и минимальный элемент массива; (2 балла)

b. Элемент массива, индекс которого ввел пользователь; (2 балла)

c. Заменить все четные элементы массива на 1, а нечетные на 0; (3 балла)

d. Количество с четными и нечетными значениями. (2 балла)

Оформить вывод (1 балл)

Ответов к вопросу: 1
  • daraselgunova
    05.11.2024 | 19:37

    from random import randint

    array = [randint(-7,7) for i in range(10)]

    print(max(array), min(array)) # максимальный и мин.Элемент массива

    try: # Элемент массива, индекс которого ввел пользователь

       print(array[int(input(«Введите элемент массива: «))])

    except: # try ; except можно убрать, если будет введён явный элемент

       print(«нет такого индекса»)

    #___________________Чётные — нечётные + заменили все четные элементы на 1 а нечёт на 0

    one = 0

    two = 0

    for i in range(len(array)):

       if array[i] % 2 == 0:

           one +=1

           array[i] = 1

       else:

           two += 1

           array[i] = 0

    print(one,two)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.