Блог для маленьких школьников и их родителей
ШколаЛа
28
Июнь

Help Pascal ABC Напишите программу, которая для произвольного четырехзначного натурального числа N Вычисляет: А)…

Автор: masyastell
Предмет: Информатика
Уровень: студенческий

Help
Pascal ABC
Напишите программу, которая для произвольного четырехзначного натурального числа N
Вычисляет:
А) произведение первой и последней цифры числа N;
Б) если число N нечетное — выводит новое число М, образованное из числа N путем
обмена местами двух последних цифр между собой (пример – было 1234, стало 1243).​

Ответов к вопросу: 1
  • zaharas14
    28.06.2024 | 15:38

    var
           n, m: Integer;

           

    begin
           Read (n);

           

           WriteLn (‘Произведение первой и последней цифры числа ‘, n, ‘: ‘, (n div 1000) * (n mod 10));

           WriteLn;

           

           if Odd (n) then begin
                   m := (n div 1000) * 1000 + (n div 100 mod 10) * 100 + (n mod 10) * 10 + (n mod 100 div 10);

                   

                   WriteLn (‘Число ‘, n, ‘ нечётное, поэтому новое число равно: ‘, m);
           end;
    end.        

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.