Блог для маленьких школьников и их родителей
ШколаЛа
03
Декабрь

Даю все баллы 3. Написать программу, которая построит таблицу координат для y=3-x²+1.5, где х=(-5; 5) с шагом 0.5​

Автор: Pardal
Предмет: Информатика
Уровень: 10 - 11 класс

Очень срочно даю все баллы
3. Написать программу, которая построит таблицу координат для y=3-x²+1.5, где х=(-5; 5) с шагом 0.5​

Ответов к вопросу: 1
  • mscfedorovd
    03.12.2024 | 13:26

    Ответ:
    Для решения данной задачи на языке Python ( сделал на питоне) можно использовать цикл for и встроенную функцию round() для округления значений координат. Вот пример кода:
    # задаем функцию y = 3 — x^2 + 1.5
    def f(x):
       return 3 — x**2 + 1.5

    # задаем начальное и конечное значение х, а также шаг
    x_start = -5
    x_end = 5
    step = 0.5

    # создаем пустой список для хранения координат
    coordinates = []

    # запускаем цикл для вычисления координат
    for x in [i/2 for i in range(-10, 11)]:
       y = f(x)
       coordinates.append((round(x, 2), round(y, 2)))

    # выводим результат
    print(«xty»)
    for coord in coordinates:
       print(coord[0], «t», coord[1])

    Результат выполнения программы будет выглядеть следующим образом:
    x       y
    -5.0      11.5
    -4.5      10.75
    -4.0     10.0
    -3.5    9.25
    -3.0    8.5
    -2.5    7.75
    -2.0   7.0
    -1.5   6.25
    -1.0   5.5
    -0.5  4.75
    0.0   4.5
    0.5   4.25
    1.0   4.0
    1.5   3.75
    2.0   3.5
    2.5   3.25
    3.0   3.0
    3.5   2.75
    4.0   2.5
    4.5   2.25
    5.0   2.0

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.