Блог для маленьких школьников и их родителей
ШколаЛа
08
Декабрь

Напишите программу, в которой создается список из нескольких элементов и потом этот список выводится на печать в виде…

Автор: jahongir16
Предмет: Информатика
Уровень: студенческий
Фото к вопросу: Напишите программу, в которой создается список из…

Напишите программу, в которой создается список из нескольких элементов и

потом этот список выводится на печать в виде таблички индекс – значение

питон

Ответов к вопросу: 1
  • olesyapinchyk07
    08.12.2024 | 09:31

    №1
    a = [int(input(‘Введите значение: ‘)) for _ in range(int(input(‘Введите кол-во значений: ‘)))]
    for i in range(len(a)):
       print(‘индекс ‘, i, ‘, значение ‘, a[i], sep=»)
    №2
    a = [int(input(‘Введите значение: ‘)) for _ in range(int(input(‘Введите кол-во значений: ‘)))]
    a.reverse()
    for i in range(len(a)):
       print(‘индекс ‘, i, ‘, значение ‘, a[i], sep=»)
    №3
    import random

    print([random.randrange(10, 1000) for _ in range(int(input(‘Введите кол-во покупок: ‘)))])
    №4
    import random

    a = [random.randrange(10, 1000) for _ in range(int(input(‘Введите кол-во покупок: ‘)))]
    print(a)
    print(‘Выручка составляет’, sum(a), ‘рублей’)
    №5
    import random

    a = [random.randrange(10, 1000) for _ in range(int(input(‘Введите кол-во покупок: ‘)))]
    print(a)
    print(‘Выручка составляет’, sum(a), ‘рублей’)
    print(‘Сумма наибольшей покупки составляет’, max(a), ‘рублей’)
    print(‘Сумма наименьшей покупки составляет’, min(a), ‘рублей’)
    №6
    import random

    a = [random.randrange(1, 50) for _ in range(int(input(‘Введите кол-во покупок: ‘)))]
    print(‘——————————-‘)
    print(‘| Число | Сумма от 1 до числа |’)
    for i in range(len(a)):
       print(‘——————————-‘)
       print(‘|’, a[i], ‘ | ‘, sum(range(1, a[i]+1)), ‘ |’)
    print(‘——————————-‘)
    Тут можно поиграть с таблицей, чтобы было хорошо было видно, а значения верные.
    №7
    import random

    a = [random.randrange(1, 100) for _ in range(random.randrange(10, 20))]
    b = int(input(‘Введите ограничение: ‘))
    q = []
    print(a)
    for i in a:
       if i < b:
           q += [i]
    print(q)

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.