Блог для маленьких школьников и их родителей
ШколаЛа
26
Ноябрь

Составить программу следующей задачи: на вход подается число. Из этого числа выделить сколько в нем 1000, сколько…

Автор: frolovalizka586
Предмет: Информатика
Уровень: 5 - 9 класс

Составить программу следующей задачи: на вход подается число. Из этого числа выделить сколько в нем 1000, сколько — 500, сколько — 100, сколько — 10 и оставшиеся единицы.

Ответов к вопросу: 1
  • vladaovodenko16
    26.11.2024 | 17:37

    ===== PascalABC.NET =====
    begin
     var n := ReadInteger(‘Введите число’);
     Write(n, ‘ = ‘);
     var t1000 := n div 1000;
     n := n mod 1000;
     var t500 := n div 500;
     n := n mod 500;
     var t100 := n div 100;
     n := n mod 100;
     var t10 := n div 10;
     n := n mod 10;
     Write(t1000, ‘ x 1000 + ‘, t500, ‘ x 500 + ‘,
         t100, ‘ x 100 + ‘, t10, ‘ x 10 + ‘, n, ‘ x 1’)
    end.

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.