Блог для маленьких школьников и их родителей
ШколаЛа
29
Июль

С задачей даю 35 баллов Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n дней…

Автор: holmatovadiana17
Предмет: Информатика
Уровень: 5 - 9 класс

Помогите пж с задачей даю 35 баллов

Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n

дней. Требуется определить, в какие дни осадков не было.

Формат входных данных

На первой строке входного файла записано натуральное число n

(n≤100)

— число элементов в массиве.

На следующей строке через пробел записаны целые числа ai

(0≤ai≤103) — количество осадков в i

-й день.

Формат выходных данных

Требуется в одной строке через пробел вывести индексы дней, в которые осадков не было.

входные данные

4

100 20 0 318

10

0 0 0 0 0 47 777 66 89 6

выходные данные

2

0 1 2 3 4

Ответов к вопросу: 2
  • xvc9da6bxr
    29.07.2024 | 18:44

    Ответ:
    #include <iostream>

    #include <vector>

    using namespace std;

    signed main(){

      vector<int> a, res;

      int n;

      cin >> n;

      a.resize(n);

      for(int i = 0; i < n; i++){

          cin >> a[i];

          if(a[i] == 0)

              res.push_back(i);

      }

      for(auto &i : res) cout << i << » «;

    }
    Объяснение:

  • tesna
    29.07.2024 | 19:03

    #include <iostream>
    #include <vector>

    using namespace std;

    signed main(){
       vector<int> a, res;
       int n;
       cin >> n;
       a.resize(n);
       for(int i = 0; i < n; i++){
           cin >> a[i];
           if(a[i] == 0)
               res.push_back(i);
       }
       for(auto &i : res) cout << i << » «;
    }

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.