Блог для маленьких школьников и их родителей
ШколаЛа
25
Август

1 ЗАДАНИЕ И 35 БАЛЛОВ: Напишите программу, которая вычисляет сумму чисел от 1 до n, где n целое число, вводимое с…

Автор: aleksandra9787
Предмет: Информатика
Уровень: 5 - 9 класс

1 ЗАДАНИЕ И 35 БАЛЛОВ:

Напишите программу, которая вычисляет сумму чисел от 1 до n, где n целое число, вводимое с клавиатуры. В программе используйте цикл for. Ввод и вывод данных выполните с пояснением.

Ответов к вопросу: 1
  • N1kola1zz
    25.08.2024 | 18:42

    (от 1 до n Не включительно)
    Код:n = int(input(«n = «))
    sum = 0
    for i in range(1,n):
       sum += i
    print(«Сумма чисел от 1 до», n, «=», sum)

    Ввод/Вывод:n = 10                                                                                                                        

    Сумма чисел от 1 до 10 = 45

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.