Блог для маленьких школьников и их родителей
ШколаЛа
30
Июль

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число. Найти сумму и произведение его…

Автор: koly50
Предмет: Информатика
Уровень: 5 - 9 класс

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число.

Найти сумму и произведение его цифр.

Ответов к вопросу: 1
  • zhanelserikbaeva8
    30.07.2024 | 12:14

    Ответ:
    #include <iostream>

    int main()

    {

    int N, s1 = 0, s2 = 1;

    setlocale(LC_ALL, «Russian»);  // Русский язык в консоли

    std::cin >> N;

    while (N > 0)

    {

     s1 += N % 10;

     s2 *= N % 10;

     N /= 10;

    }

    std::cout << «Сумма: » << s1 << std::endl;

    std::cout << «Произведение: » << s2;

    return 0;

    }

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.