Блог для маленьких школьников и их родителей
ШколаЛа
04
Сентябрь

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку…

Автор: davkon1324
Предмет: Информатика
Уровень: 5 - 9 класс

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку «5», на экран выводится словесная отметка «Пятерка»

2)Напишите альтернативную программу с применением оператора if для 1-ой задачи

Ответов к вопросу: 1
  • ankazev241
    04.09.2024 | 11:15

    Ответ:
    var i:integer;  
    begin  
    writeln(‘Введите оценку’); readln(i);  
    case i of  
    1: writeln(‘Единица’);  
    2: writeln(‘Двойка’);  
    3: writeln(‘Тройка’);  
    4: writeln(‘Четверка’);  
    5: writeln(‘Пятерка’);  
    else writeln(‘Нет такой оценки’);  
    end;  
    readln;  
    end.

    Альтернативная задача
    var i:integer;  
    begin  
    writeln(‘Введите оценку’); readln(i);  
    if i = 1 then writeln(‘Единица’)
    else if i = 2 then writeln(‘Двойка’)
    else if i = 3 then writeln(‘Тройка’)
    else if i = 4 then writeln(‘Четверка’)
    else if i = 5 then writeln(‘Пятерка’)
    else writeln(‘Нет такой оценки’);    
    readln;  
    end.
    Объяснение:

Ответить на вопрос:
:p :-p 8) 8-) :lol: =( :( :-( :8 ;) ;-) :(( :o:
Нажимая на кнопку я даю согласие на обработку персональных данных и принимаю политику конфиденциальности.